ST Math Status
Incident Report for STMath
Resolved
This incident has been resolved.
Posted Jul 31, 2020 - 17:12 PDT
Update
We are continuing to investigate this issue.
Posted Jul 31, 2020 - 17:12 PDT
Investigating
The teacher console is experiencing a degradation of service. Some teacher and admin accounts are not seeing their classes or students. Students are unaffected and able to play as normal. We are aware of the issue and are looking into the cause.
Posted Jul 31, 2020 - 10:00 PDT
This incident affected: ST Math - play.stmath.com Teacher Console.