ST Math Status
Incident Report for STMath
Resolved
We have identified a fix for the problem and service should be restored
Posted Mar 03, 2021 - 16:01 PST
Investigating
We are investigating a reported incompatibility with Chrome 89. We will post updates as soon as they are available.
Posted Mar 03, 2021 - 15:26 PST
This incident affected: ST Math - play.stmath.com Staff Experience and ST Math - play.stmath.com Learner Experience.