ST Math Classlink SSO Login Experiencing Issues with Some Users
Incident Report for ST Math
Postmortem

ST Math Outage Notice and ResolutionSome of our users experienced difficulties authenticating into ST Math between 5:31 AM and 9:00 AM PDT on May 15th, 2024. We apologize for any inconvenience this may have caused.
What Happened:
The outage was caused by a failed update that resulted in unexpected errors for some users. These errors were due to code issues that were not discovered because some important test cases were missed.
How We Fixed It:
Our team worked diligently to identify and resolve the issue. The service was fully restored by 9:00 AM PDT.

Posted May 15, 2024 - 13:14 PDT

Resolved
This incident has been resolved.
Posted May 15, 2024 - 09:15 PDT
Monitoring
We have identified and corrected the issue.
Posted May 15, 2024 - 09:11 PDT
Update
We are continuing to investigate.
Posted May 15, 2024 - 07:07 PDT
Update
Our Engineering team is working to identify the issue.
Posted May 15, 2024 - 06:43 PDT
Investigating
Our engineering team is working to identify the root cause and implement a solution.
Posted May 15, 2024 - 05:31 PDT
This incident affected: ST Math Staff Experience, ST Math Learner Experience, and ClassLink My Apps.