ST Math is experiencing issues for some users
Incident Report for STMath
Resolved
This incident has been resolved.
Posted Nov 08, 2021 - 13:13 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 08, 2021 - 11:24 PST
Investigating
Our engineering team is working to identify the root cause and implement a solution.
Posted Nov 08, 2021 - 10:27 PST
This incident affected: ST Math - play.stmath.com Staff Experience and ST Math - play.stmath.com Learner Experience.