ST Math Experiencing a Degradation of Service
Incident Report for ST Math
Resolved
This incident has been resolved by AWS engineers.
Posted Sep 18, 2023 - 13:44 PDT
Update
We continue to monitor this situation with the Amazon outage (https://health.aws.amazon.com/health/status) and will provide updates as quickly as they are made available to us.
Posted Sep 18, 2023 - 13:01 PDT
Update
We are continuing to monitor this AWS outage.
Posted Sep 18, 2023 - 12:36 PDT
Update
We are continuing to monitor this AWS outage.
Posted Sep 18, 2023 - 12:14 PDT
Identified
Amazon Web Services (AWS) has confirmed they are having issues with their infrastructure that is impacting ST Math. We are continuing to monitor.
Posted Sep 18, 2023 - 12:01 PDT
Investigating
We are currently experiencing a service degradation.

Our engineering team is working to identify the root cause and implement a solution.
Posted Sep 18, 2023 - 11:31 PDT
This incident affected: ST Math Staff Experience and ST Math Learner Experience.