ST Math is experiencing issues for some users
Incident Report for STMath
Resolved
This incident has been resolved.
Posted Nov 09, 2021 - 11:33 PST
Update
We are continuing to monitor for any further issues.
Posted Nov 09, 2021 - 11:23 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 09, 2021 - 11:23 PST
Investigating
We are currently investigating this issue.
Posted Nov 09, 2021 - 11:13 PST
This incident affected: ST Math - play.stmath.com Staff Experience and ST Math - play.stmath.com Learner Experience.