ST Math Rostering system is down for scheduled maintenance
Incident Report for STMath
Resolved
This incident has been resolved.
Posted Oct 30, 2021 - 07:11 PDT
Investigating
ST Math Rostering system is down for scheduled maintenance for the remainder of the week. No accounts will be created or updated, but existing users will be able to sign in and use ST Math normally. Your changes and additions will be available once rostering resumes this weekend.
Posted Oct 27, 2021 - 14:14 PDT
This incident affected: ST Math - play.stmath.com Staff Experience and ST Math - play.stmath.com Learner Experience.