ST Math Status
Incident Report for STMath
Resolved
This incident has been resolved.
Posted Sep 14, 2020 - 08:42 PDT
Update
Our Engineering team has found and addressed the issue, all systems are operational
Posted Sep 14, 2020 - 08:41 PDT
Investigating
We are experiencing problems with SSO logins from tools such as Clever. Our engineering team is investigating.
Posted Sep 14, 2020 - 08:20 PDT
This incident affected: ST Math - play.stmath.com Students Access.