ST Math Experiencing an issue with staff functionality.

Incident Report for ST Math

Resolved

This incident has been resolved.
Posted Apr 14, 2023 - 08:53 PDT

Update

We are continuing to investigate this issue.
Posted Apr 14, 2023 - 08:52 PDT

Update

We are continuing to investigate this issue.
Posted Apr 14, 2023 - 08:51 PDT

Investigating

We are currently experiencing an issue with staff functionality. Staff are not able to launch and play games from the teacher console.

Our engineering team is working to identify the root cause and implement a solution.
Posted Apr 14, 2023 - 07:47 PDT
This incident affected: ST Math Staff Experience.