ST Math Status
Incident Report for STMath
Resolved
This incident has been resolved.
Posted Jul 31, 2020 - 09:44 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 31, 2020 - 08:00 PDT
Investigating
The system is experiencing a degradation of service. We are aware of the issue and are looking into the cause.
Posted Jul 31, 2020 - 07:48 PDT
This incident affected: ST Math - play.stmath.com Teacher Console.