ST Math Status
Incident Report for STMath
Resolved
This incident has been resolved.
Posted Jul 29, 2020 - 18:48 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 29, 2020 - 17:00 PDT
Identified
The system is experiencing a degradation of service. We are aware of the issue and are looking into the cause.
Posted Jul 29, 2020 - 16:39 PDT
This incident affected: ST Math - play.stmath.com Teacher Console.