Homeschool Student Login Issues

Incident Report for ST Math

Resolved

The issue has been resolved and homeschool learners are now able to log in and play. We will continue to monitor.
Posted Mar 20, 2023 - 17:14 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 20, 2023 - 16:53 PDT
This incident affected: ST Math - Homeschool Student.